Upgrading Ubuntu - "Error authenticating some packages"

Contact us

Upgrading Ubuntu - "Error authenticating some packages"

Sometimes when upgrading Ubuntu you'll see this error message:

Error authenticating some packages
It was not possible to authenticate some packages. This may be a transient network problem. You may want to try again later. See below for a list of unauthenticated packages

Temporary workaround, create file

/etc/update-manager/release-upgrades.d/unauth.cfg

filled with the following

[Distro]
AllowUnauthenticated=yes

Now your sudo do-release-upgrade should run OK.

Make sure to remove this file once upgrade process is completed.

Source: http://sysadm.mielnet.pl/upgrading-ubuntu-10-04-to-12-04-error-authenticating-some-packages/

30 January 2018